Jump to content

Search the Community

Showing results for tags 'privia px-330 '.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Casio Discussion
    • General Casio Discussion
    • Casio Cast
    • Share your music here
  • XW-series
    • General Discussion
    • XW-Series and the iPad
    • XW Sequencing
    • XW-P1 Specific
    • XW-G1 Specific
    • XW Downloads
    • XW-J1
    • XW-PD1
  • Privia Stage Pianos
    • Privia Pro PX-5S
    • PX-560M
    • PX-3S
  • Privia & Celviano Digital Pianos
    • General Discussion
    • Celviano Grand Hybrid Series
    • PX-360 and CGP-700
    • Privia x50 x60 Series
    • Celviano AP-x50 and x60 Series
    • Privia x30 Series
    • Celviano AP-x20 Series
  • MZ-X Series
    • MZ-X500 / MZ-X300
  • CTK / WK / LK Portable Keyboards
    • General Discussion
    • WK-7500/7600 - CTK-7000/7200
    • WK-6500/6600 - CTK-6000/6200
    • Other CTK/WK Models
    • LK-series
  • Classic Casio
    • Classic Casio Discussion

Categories

  • CASIO Official Files
    • Privia PX-5S
    • Privia PX-560
    • MZ-X
    • XW-Synths
    • XW-PD1
  • Community Created Files
    • Privia PX-5S
    • PX-560
    • XW-Synths
    • CTK / WK
    • MZ-X
  • Other Casio Products

Found 1 result

  1. I recently bought a used Casio Privia PX-330 to donate to our new church. Suddenly, the unit powers on but the display says “Waiting…” and it never full powers up for performance. What could be the problem here and have any of you shipped a Privia to be serviced? I have no dealerships or authorized repair places in town. If any of you could be of help we would greatly appreciate it. Thank you for your time, Bill Rebsamen
×