Jump to content
Egor

Rhodes sounds distorting PA

Recommended Posts

Could not be happening at all the stages with all different gear and soundmen. While other keyboards sound just fine. As I said I'm yet to test my brand new replaced 560 but that's how the issue was happening for me with the one that I had replaced.

Share this post


Link to post
Share on other sites

Brad, with all due respect, its not that simple. And for the record I had a PX 5 before this and out of the box IT had overdriven outputs issues. Particularly when playing left hand basslines and right hand keys. Even AP's. And one should NOT have to go through and edit every sound (not that there are that many user slots) on the keyboard to adjust all the levels, effects levels and overall EQ etc etc. That's ridiculous. Never EVER had this issue with Roland Yamaha Kurzweil or Korg boards and I set them up exactly the same way!

 

I suspect on the 560 it is setup (with gain staging and levels) to match the onboard speakers, as they figure that most buyers will be home users using it with onboards and nto running through desks and PA's.

 

 

Share this post


Link to post
Share on other sites

These two models will clip internally for only a couple of reasons.  From the factory, a properly functioning unit will not clip. I'm certain they have been tested against this. 

 

1. If it is clipping internally (using headphones connected directly to the keyboard at midway volume level) and a factory reset or initalize all does not cure the issue, internal components need repair.  

 

2. If it is clipping with headphones and a reset does indeed fix the problem, the user has adjusted internal gain staging in an improper manner.  

 

All other issues have to be with external gear, not the keyboard.

Share this post


Link to post
Share on other sites

Well, sorry, but you are wrong! Not using headphones at all for a start. Look Brad, I know you are experienced with the PX5s but as you yourself have admitted you do not own a 560 so perhaps its best if you don't comment on a board you dont own.

 

Oh and btw , from the factory the px-5s DID clip.

 

As Egor says, he is basing this not onyl on his experiecne but also the testimony of audio professionals. And tell my why if I hook up say a Korg Kross, using very similar patches and keys setups there is NO clipping from its audo outs? Nothing has changed.

 

Simply trying to blame it on external gear is just burying your head in the sand afaics.

Share this post


Link to post
Share on other sites

Do you still have your PX-5S? Do you recall which stage setting was causing clipping?  I'll try to reproduce the issue.  I haven't had any issues with mine so far or on the MZ-X500.

Share this post


Link to post
Share on other sites

Yeah I still have the PX-5 ...its been so long and i have adjusted all the sounds so much, I'm not sure I could now recall. But as a general thing, it ws mostly the EP's - even those without DSP distortion, especially when a left hand bass was added. although at higher velocities even the EPs by themselves could overload the output gain staging.

 

The common thing seems to be if you run the main volume knob at less than half (this I found, was the same albeit to a lesser degree on the 5s) - probs 1/3 to 1/2 it dramatically reduces the overloading, which indicates, to me anyway, that something is not set right. Once the knob gets to past half then the clipping starts, moreso with low frequency heavy sounds like the EPs, but if one is playing APs (rock and roll for eg) and more energy is going on to the keybed, then even they can be heard to overload the outs. Not sure if this is a hardware thing, ergo not fixable, or whether a firmware update could fix it??

 

As I wrote earlier, it (the 560) does SEEM to go into overload quicker, or I should say earlier, and I suspect this is becasue its audio is setup for using the on-board speakers, not live PA audio. One thing I notice is that volume for ALL patches in the bootup registration are set to 127 and any patch loaded seems to default to 127. Now perhaps the overloading of the out jacks could be ameliorated (haha love that word!) by resetting all these levels to say 100+ however as one cannot over-write factory patches, we are left with the user slots and these will quickly run out if one starts saving all the adjusted for volume patches. Especially as I need to have many of my patches setup with specific note ranges (for running external gear) however on the 560 this is ONLY possible by creating hex tones! And thereby using precious user slots. Just like the 5s, it is a board that is ALMOST there, but falls down in some critical areas IMO. However that is going OT so wold be the subject of another thread hahaha.

 

I actually like the 560 (although being able to add user created midi parts to the arranger section would be nice!) so I am trying to see some sort of viable workaround. Even registrations are limited, and as there is no way to dynamically load these from USB memory it is probably another dead-end workaround method. Although I suppose a user could create four patches per screen. What I mean by this is I could create four different APs in one registration, and then simply use the "activate" tab live. Casio are not making it easy for pros to use this 560, however with no PX 5 replacement on the horizon, it seems it is the only option.

 

 

Share this post


Link to post
Share on other sites

For what it is worth, when I began to edit/create tones and registrations on the 560 I began to notice some light to moderate overdrive distortion. I traced it to the 560 and not external gear. What I found is that when I added light compression  and very slightly increased the gain of the EQ it caused the overdriving distortion. For me, by reducing slightly the gain stages of the compression and EQ the problem was corrected. I also noticed that the output was ever so slightly less dynamic.

My opinion is that by running the gain stages to the max before clipping Casio have given us some great and dynamic sounds to work with. The down side just may be that it is easily overdriven internally. 

Just something to think about.

Share this post


Link to post
Share on other sites

thanks fearless, was this done as a "system wide" thing or on a tone by tone basis? IE if system wide, is it a setitng that "sticks"? FWIW everything on my 560 sis at "factory settings" so no adjustments to compression or EQ have been made. Certainly no "gains"

 

 

Share this post


Link to post
Share on other sites
1 hour ago, pax-eterna said:

thanks fearless, was this done as a "system wide" thing or on a tone by tone basis? IE if system wide, is it a setitng that "sticks"? FWIW everything on my 560 sis at "factory settings" so no adjustments to compression or EQ have been made. Certainly no "gains"

 

 

It was done  at the individual tone level, but not system wide. I almost never use tones/patches right out of the box. The clipping I was getting was on acoustic pianos.

Share this post


Link to post
Share on other sites

thanks. haha I don't either. But the only way to fix this I think is to re-create all the tones I want to use on a regular basis and save them to user slots, then re-program all the registrations to use these edited tones.

 

But again, it really shouldn't be necessary to do all this JUST to stop clipping haha!

Share this post


Link to post
Share on other sites
8 minutes ago, fearless said:

It was done  at the individual tone level, but not system wide. I almost never use tones/patches right out of the box. The clipping I was getting was on acoustic pianos.

That's where I was getting most of the clipping from - the acoustic pianos...

Share this post


Link to post
Share on other sites

Oh and just an aside....if I have the master volume knob pointed at the V in Volume, no clipping occurs. Move it a millimetre right and clipping restarts.That, to me, confirms it IS an output jack driver/hardware issue.

Share this post


Link to post
Share on other sites

One possibility that is not been mentioned here is whether or not the built-in speakers are active or disabled.   The PX-560 like all Privia models with speakers has a final EQ stage that is specifically for the built-in speaker system.  The only way this EQ can be bypassed is to disable the speaker system. This will provide a flat audio signal to the line output and I suspect may solve the issue.  This is mentioned in the manual although the Japanese to English may not be so clear.

Share this post


Link to post
Share on other sites

Me too! Always had, always do. It annoys me... But still had that clipping issue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×