Jump to content

Recommended Posts

5 minutes ago, Rick Sterling said:

 

Yes, no problem with loading registration when rhythm is playing. You'll need to create a YouTube video to show us the issue. I can't seem to replicate it here.

 

OK I think I see what you are talking about. If you program a registration with synchro start Intro 1 when you select that registration while playing another rhythm it goes immediately to Variation 1 not Intro 1.  Not sure how I feel about that, it's not a 'feature' I would ever use in my playing as when I change rhythms in the middle of a song I don't want the intro to play again. Looks like a two handed approach is needed. Press the new registration with your right hand while pressing Intro 1 with your left? ;-)

Share this post


Link to post
Share on other sites
31 minutes ago, Rick Sterling said:

 

Yes, no problem with loading registration when rhythm is playing. You'll need to create a YouTube video to show us the issue. I can't seem to replicate it here.

Rick before making a video.
1-Save a rhythm in the registration memory with start Sync in INTRO 1 or 2.
2-Press and play another Rhythm and press the registration you saved with freeze off and with the rhythm Playing to see if it enters the INTRO that you saved

Share this post


Link to post
Share on other sites
24 minutes ago, Rick Sterling said:

 

OK I think I see what you are talking about. If you program a registration with synchro start Intro 1 when you select that registration while playing another rhythm it goes immediately to Variation 1 not Intro 1.  Not sure how I feel about that, it's not a 'feature' I would ever use in my playing as when I change rhythms in the middle of a song I don't want the intro to play again. Looks like a two handed approach is needed. Press the new registration with your right hand while pressing Intro 1 with your left? ;-) :cheers:

Yeeessss. And what did you say.
Now imagine a scenario in which you play a presentation of two different songs in which you want to link these songs and in the second song you have created an intro (INTRO 1 or INTRO 2) and then go to the variations.
If registration does not save the link through INTRO 1 or 2.
You do not need this today but many need and who knows for you in the future.

Share this post


Link to post
Share on other sites
1 hour ago, CoreyW said:

Rick, I'm wondering if Silvano means "loading" a rhythm and/or style from a defined MIDI file (like a Yamaha STY file) into the MZ-X where the Intro and Ending data may not load?  If so, I think there might be a bit of a translation issue with what he means by saving into the MZ-X instead of loading into the MZ-X.

 

If so, I've had this same issue with Yamaha STY files.  I think most people know that the STY files are nothing more than a MIDI file renamed to .STY file.  The STY files contain markers to detail the different parts; INTRO, MAIN, VARIATIONS, FILLS and ENDINGS.  The formatting seems really specific and is a little different based on the manufacturer.  To many details to go into here, but Casio does do it very well.  I've found that if you want a more robust import, then you have to figure out the formatting for where ever the file came from and edit the MIDI files to be more specific.  Yes, a pain, but it does work!!

 

Just my 2 cents...

Friend CoreyW.
The STY import tool until it works.
But that's not what I mean.
I was commenting on the evolution of Yamaha PRS and STY rhythms.
Casio "evolved" from CPT CKF Z00 to AC7
The AC7 extension still needs enhancements to support the MZ-X

As for reading STY rhythms what I advise is to rename the STY extension to MID and open it in a DAW (I recommend SONAR with INS file from RICK THAT HAS TO DOWNLOAD here in the FORUM)
Editing the Rhythm connected to DAW and MZ-X.
Then you put the edited MID and import into the MZ-X

Share this post


Link to post
Share on other sites
19 minutes ago, Silvano Silva said:

Yeeessss. And what did you say.
Now imagine a scenario in which you play a presentation of two different songs in which you want to link these songs and in the second song you have created an intro (INTRO 1 or INTRO 2) and then go to the variations.
If registration does not save the link through INTRO 1 or 2.
You do not need this today but many need and who knows for you in the future.

 

If I ever ,need to do this the two handed approach works fine for me.

Share this post


Link to post
Share on other sites
3 minutes ago, Rick Sterling said:

 

If I ever ,need to do this the two handed approach works fine for me.

Each has an operational mode to work with.
Many of these features you will find in other brands.
It may not suit you, but it will not hurt you in any way.

Share this post


Link to post
Share on other sites
17 hours ago, Silvano Silva said:

Friend CoreyW.
The STY import tool until it works.
But that's not what I mean.
I was commenting on the evolution of Yamaha PRS and STY rhythms.
Casio "evolved" from CPT CKF Z00 to AC7
The AC7 extension still needs enhancements to support the MZ-X

As for reading STY rhythms what I advise is to rename the STY extension to MID and open it in a DAW (I recommend SONAR with INS file from RICK THAT HAS TO DOWNLOAD here in the FORUM)
Editing the Rhythm connected to DAW and MZ-X.
Then you put the edited MID and import into the MZ-X

 

Sorry, I misunderstood!  But yes, that is exactly what I do.  As a side note and I've mentioned this before, but the track names seem to be non-existent in the MZ-X even though they appear in the MIDI files when opened with a computer program like Anvil Studio, Power Tracks and even Sonar (Cakewalk).  There is a standard in the MIDI spec that is designated for Track names as a meta-event.  Either there is a bug, or I'm just missing something.  It would be nice to see the track names listed in the MZ-X since the feature is there, but it just doesn't seem to work.

Share this post


Link to post
Share on other sites
4 minutes ago, CoreyW said:

 

Sorry, I misunderstood!  But yes, that is exactly what I do.  As a side note and I've mentioned this before, but the track names seem to be non-existent in the MZ-X even though they appear in the MIDI files when opened with a computer program like Anvil Studio, Power Tracks and even Sonar (Cakewalk).  There is a standard in the MIDI spec that is designated for Track names as a meta-event.  Either there is a bug, or I'm just missing something.  It would be nice to see the track names listed in the MZ-X since the feature is there, but it just doesn't seem to work.

The DAW edit tool helps you pre-listen how it sounds in MZ.
Importing the midi to the MZ-X has to remix to the internal Mixer.
I do not know if it's bug or me that I'm doing the wrong way. But over time I'm going to edit a little sequence in DAW and see how the MZ behaves.

Share this post


Link to post
Share on other sites
On 9/6/2017 at 1:38 PM, Jazzman said:

I found a couple other quirks.  I haven't spent time trying to figure out what causes them.  

 

Occasionally the accompaniment rhythm locks up with just the drum set and no keys will play.  There is no recovery other than a power cycle.  This hasn't happened to me during a performance yet but when it does I'll be retiring the MZ-X500.

 

When using the midi recorder and trying to save the performance to a USB memory stick I sometimes get a "no attached media" message which cannot be fixed by simply removing and replugging the usb stick.  This is after successfully saving a few prior midi recordings to the same memory stick!  Power cycle is required to recognize the memory stick.

Here is a video showing the keyboard locking up when trying to play an audio recording after it has been successfully created.  Most of the time it is necessary to physically unplug the keyboard to clear the fault.  Rarely, on occasion, if the power button is depressed for an extended period that will clear the fault. I should also say that I have installed the latest OS Update.

 

Here is a link to Youtube video:  

 

Edited by Jazzman
Removed large video file and added a link to Youtube.

Share this post


Link to post
Share on other sites

Operating system need an update that is obvious why is not coming yet who knows also no new videos from Rich or Ralph fells like they given up on MZ series.

Share this post


Link to post
Share on other sites
9 hours ago, Jazzman said:

Here is a video showing the keyboard locking up when trying to play an audio recording after it has been successfully created.  Most of the time it is necessary to physically unplug the keyboard to clear the fault.  Rarely, on occasion, if the power button is depressed for an extended period that will clear the fault. I should also say that I have installed the latest OS Update.

 

Here is a link to Youtube video:  

 

 

 

I'm thinking something is not right about that particular usb flash drive. Is it a brand name drive under 32gigs in size?  Have you tried another drive?

Share this post


Link to post
Share on other sites
9 hours ago, Jazzman said:

Here is a video showing the keyboard locking up when trying to play an audio recording after it has been successfully created.  Most of the time it is necessary to physically unplug the keyboard to clear the fault.  Rarely, on occasion, if the power button is depressed for an extended period that will clear the fault. I should also say that I have installed the latest OS Update.

  

 

 

Jazzman,

 

How many recordings did you do in one continuous session before the keyboard locked up?  I think I have seen this behavior myself when I was doing a long series of recording sessions. Makes me think there might be a memory leak in the OS related to the Audio Recorder. After a period of time the OS loses enough memory to these processes that it eventually freezes the OS. Not nice. 

Share this post


Link to post
Share on other sites
47 minutes ago, Leonh said:

Operating system need an update that is obvious why is not coming yet who knows also no new videos from Rich or Ralph fells like they given up on MZ series.

 

Maybe they're busy creating new videos for the new MZ's ;-)

Share this post


Link to post
Share on other sites
23 minutes ago, BradMZ said:

 

 

I'm thinking something is not right about that particular usb flash drive. Is it a brand name drive under 32gigs in size?  Have you tried another drive?

I have two Silicon Power 16gig flash drives, they both have this problem.  I recently purchased a third with 32gig and I am starting to use it.  I didn't format the 16gig drives on the MZ-X500 but I did for the 32gig drive.  Could this be the issue?  I'll let you know how it goes.

Share this post


Link to post
Share on other sites
44 minutes ago, BradMZ said:

 

 

I'm thinking something is not right about that particular usb flash drive. Is it a brand name drive under 32gigs in size?  Have you tried another drive?

 

If it is the USB drive then there's still the issue of MZ-X OS error handling. ;-)

 

The OS should make sure the USB drive is the right size, tested, formatted and ready for use.

 

Error handling is the one way for mfgs to cut corners to save time and firmware memory. Unfortunately when they do this you end up with fragile systems that will crash or freeze if the environment is not perfect.

Share this post


Link to post
Share on other sites
18 hours ago, Jazzman said:

Here is a video showing the keyboard locking up when trying to play an audio recording after it has been successfully created.  Most of the time it is necessary to physically unplug the keyboard to clear the fault.  Rarely, on occasion, if the power button is depressed for an extended period that will clear the fault. I should also say that I have installed the latest OS Update.

 

Here is a link to Youtube video:  

 

Congratulations.
One more bug for the list !!!
Next!!!

Share this post


Link to post
Share on other sites

to Jazzman, hi there, 

 

     That is a very clear video explaining the problem, thanks.  Maybe recorded on a phone, but IMO better delivery than some Casio MZ-X500 video tutorials!  :)

 

   This 'freezing' fault of the Audio Recorder only once happened on my MZ-500 some time back.  Like you, I had to unplug the power to get it going.  Hasn't happened again, despite regular use and tried without success (so far) to replicate the fault.   

 

   I note that the manual says(page 46 of guide)  to stop a recording a new file by using the onscreen touch stop button (not the hard AUDIO button).   Might this be in some way relevant? 

 

   cheers

Share this post


Link to post
Share on other sites
20 hours ago, Rick Sterling said:

 

Jazzman,

 

How many recordings did you do in one continuous session before the keyboard locked up?  I think I have seen this behavior myself when I was doing a long series of recording sessions. Makes me think there might be a memory leak in the OS related to the Audio Recorder. After a period of time the OS loses enough memory to these processes that it eventually freezes the OS. Not nice. 

Probably did 10 or so before the first lock up during this session.  After that it would lock up each time a power reset with just one recording.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×