Jump to content
Carl_winslow

Step Sequencer adding By itself

Recommended Posts

Hey guys if anybody could help that would be awesome!!!!

 

Ive been using my xw g1 now for a while and it has become a part of my live setup. Since last week my step sequencer has been malfunctioning adding steps without me touching the keyboard. Is there anyway I can service this machine to get it fixed?

 I have re installed the firmware and reset the Keyboard back to factory and the problem still persists. It seems to interfere when im manipulating the synth thru the sliders.

Edited by Carl_winslow
update info

Share this post


Link to post
Share on other sites

That is bothersome it happend hope it didn't occur during the gig.

I had the same trouble sending it back was the only option but it all started when liquid fell on the 

first octave of the keyboard from there it went down hill with it. 

 

It effected the step sequencer step 9 and 15 and also the tap button reoccurring so now and then. 

  • Like 1

Share this post


Link to post
Share on other sites

Could you describe this with a few more details? I own the XW-P1 but the sequencer I think is identical.

 

1) Is this happening when the sequencer is in play mode-is playing a sequence or does it happen at random even with the sequencer off?

2) Which "mode" are you switched to when this happens-tone mode, sequencer mode or performance mode, or is it happening in any or all of those?

 

3) What are doing when you move the sliders, anything in particular-in other words are you using the sliders for the drawbar settings, or specific sequencer functions such as changing note or volume levels.

 

4) Are you using the sliders for changing the mixer settings when this happens-are you in the screen settings for the mixer?

 

The sequencer functions are pretty complicated IMO, and what the sliders do depends upon what mode you are in, and even how the slider functions are programmed. It may actually be doing what it's supposed to do but if I understand when the random notes happen, I'll have a better idea. I have completely taken apart my XW by the way and the assemblies for the buttons and switches are pretty secure so unless you've spilled anything into the keys or these have alot of wear the problem may not be that.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, XW-Addict said:

That is bothersome it happend hope it didn't occur during the gig.

I had the same trouble sending it back was the only option but it all started when liquid fell on the 

first octave of the keyboard from there it went down hill with it. 

 

It effected the step sequencer step 9 and 15 and also the tap button reoccurring so now and then. 

 

5 hours ago, Jokeyman123 said:

Could you describe this with a few more details? I own the XW-P1 but the sequencer I think is identical.

 

1) Is this happening when the sequencer is in play mode-is playing a sequence or does it happen at random even with the sequencer off?

2) Which "mode" are you switched to when this happens-tone mode, sequencer mode or performance mode, or is it happening in any or all of those?

 

3) What are doing when you move the sliders, anything in particular-in other words are you using the sliders for the drawbar settings, or specific sequencer functions such as changing note or volume levels.

 

4) Are you using the sliders for changing the mixer settings when this happens-are you in the screen settings for the mixer?

 

The sequencer functions are pretty complicated IMO, and what the sliders do depends upon what mode you are in, and even how the slider functions are programmed. It may actually be doing what it's supposed to do but if I understand when the random notes happen, I'll have a better idea. I have completely taken apart my XW by the way and the assemblies for the buttons and switches are pretty secure so unless you've spilled anything into the keys or these have alot of wear the problem may not be that.

 

 

No spills. I just transport this to and from stage and studio. Well just in studio now.

It happens in any mode. It seems as if its sending messages thru midi on second button in step sequencer. Happens very random while  im just playing thru songs not touching buttons.  Is there a casio service repair I can take this too? I really love this g1 would be a shame to take it out my rig.  Thanks guys for your response!!!

Share this post


Link to post
Share on other sites

Main headquarters for Casio USA is in Dover, NJ. I would contact that facility and see if they can help you. This is where I sent mine (actually brought it there since I am in driving distance) when I ruined it trying to upgrade the firmware. Might be better if you can find a good local tech to work on this although not many of those around. And is it still warraty covered?

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Jokeyman123 said:

Main headquarters for Casio USA is in Dover, NJ. I would contact that facility and see if they can help you. This is where I sent mine (actually brought it there since I am in driving distance) when I ruined it trying to upgrade the firmware. Might be better if you can find a good local tech to work on this although not many of those around. And is it still warraty covered?

 

Oh cool ok ill give them a call.

No I bought this when it first came out i don't think there is a warranty on it still.

Share this post


Link to post
Share on other sites

I would also look at that specific button, try to see if it seems more pressed in (collapsed) and how it feels when pushed in compared to the other sequencer buttons. Sometimes the slightest physical position of a button can be a clue that the contact below it is worn, defective or stuck. And try blowing some compressed air into it from the top of the panel on the off chance there might be a bit of dirt or other junk, even a tiny bit that could have stuck itself in underneath. And it could be a software glitch (like computers) that will disappear for no apparent reason, just as it appeared.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×