Jump to content
drfred

Help with (apparently) fried USB connection

Recommended Posts

I love my PX-130 and decided to try to hook it up as a MIDI controller. I plugged in the USB to a Mac and it made 2 other devices on the USB hub brown out - got a warning that the device was pulling too much power.

 

I tried hooking it to a Windows computer and it said that the USB device malfunctioned and could not be recognized.

 

I have tried several different cables, using a USB hub and plugging directly into the computers without success.  I do have a microKORG running as a MIDI controller, so I know the software on the computer side is fine.

 

I suspect the Casio end of this has malfucntioned somehow. Not sure if there are replaceable parts in the USB controller or if I should send it in somewhere for repair.

 

Any help that you could give would be greatly appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×