Jump to content

sharon obrien

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About sharon obrien

  • Rank
    Newbie
  1. Just bought the grand hybrid GP-300 hoping to get a real piano feel when recording my tracks but Im stuck and scared to connect to logic 8 on my mac book OSX 10.6.8 incase its not compatable and breaks it...the manual says 10.6.x is the minimum requirement and thats snow leopard, is my OSX10.6.8 just an updated version of that and ok to connect? please help so I can get set up, thanks Sharon
×