Jump to content

o0Ampy0o

Members
  • Content count

    5
  • Joined

  • Last visited

  1. I appreciate the advice, thank you.
  2. Thank you for continuing with this. I added a couple of different loop tracks and compared them to the keyboard. The keyboard is significantly lower in volume. One thing I did not mention yet is that I have swapped the USB cables during these tests. If a USB cable could be a source of something like this it would have to be coincidentally two behaving the same way.
  3. Thank you both Brad and Joe. The information you posted stimulated my mind and I immediately thought of something that could be a factor. I wanted to experiment and test an idea before posting and it took me until this evening to gather the time and go through the steps. I had not had my 2nd keyboard hooked up and it involved installing drivers and going into the onboard software to set it up as a controller. Visualizing how the headphones are plugged into the computer I remembered that the Mac Mini has a powered speaker system with its own volume control. The headphone jack works with and without this speaker system's power turned on. When I use the headphones I have the power off so the On/Off light is off. This was probably instrumental in my ignoring the fact that I had this additional boost lending itself to the audio signal. Typically I operate my computers with most of the alerts muted. I keep the OS sound volume at a standard setting and would have unconsciously customized the headphone volume using the volume knob of the speaker on my desk where the headphones are plugged in. I would not have had any occasion to measure how loud the system alerts were compared with the DAW plugin because the alerts were never triggered. This explains why I had been able to play my piano at an enjoyable level back when I was playing regularly a couple of years ago without feeling the audio signal was considerably weaker than it should be. I set up my Mac Mini the way I had back when I was playing the piano regularly. I duplicated the set up on my Mac Pro. I tried my other keyboard, a Yamaha MOX, with both systems. Then I tried the PX150 with both systems. The keyboards produce identical MIDI information. Generally, with an average suppression of a key they register between 45-63. Bringing a key down hard ranges mostly in the 80's with as much as a single 109. Kontakt has a virtual keyboard. Probably inaccurate and unreliable eye candy but worth mentioning. Like a physical acoustic piano, pressing a key close to the pivot produces a softer note and when pressed at the front edge it produces the loudest note. If anything can be gathered from this both keyboards only achieve midrange volume or less and I have never been able to reach beyond 109. It took a significant thump to get to 109 and I doubt anyone would ever play that hard. I have not played my keyboards regularly for over two years. I may have only tinkered a little a couple of times during this period. I don't even really know how to "play" piano. I just noodle around but I had developed comfort and familiarity. The piano action of the PX150 feels awkward to my rusty hands but the MOX feels fine. I started out with the MOX and was ready for a piano action when I purchased the Casio so it was a well-timed transition. This current awkwardness has been a factor in my perception of the response I was experiencing which prompted me to start this thread. In conclusion, the audio produced by a bare keyboard seems inadequate at default settings in the OS and software. The boost from the external speaker system is necessary to attain a comfortable experience. Without this boost from the external speaker system I have to set the OS audio to max and increase the software volume and adjust the velocity curve. This is a slippery slope leading to undesirable side effects. So I am just going to connect the speaker system to whichever computer I am playing through.
  4. I have tried playing a video with Quicktime and the audio behaves normally. I also have a program called MIDI Monitor that confirms the signal is being produced and received from the keyboard. Audio Midi Setup automatically detects and produces an icon for the keyboard as well. Because this problem is consistent between three different computers I am suspecting it might be a consistent error in set up however the user guide describes a very simple process and I had never had any trouble getting things working before. On the other hand I have not ruled out user error because the last two years have been significantly stressful and I experienced a lot of sleep deprivation. I have been surprised by uncharacteristic mishaps and mistakes. One other thing I am not sure really exists or is just an illusion from the one described problem but it sort of seems like the keyboard is not as sensitive as it had been. I used to be able to coax subtlety from it but along with the requirement to force the keys to produce volume it seems as though it has become more a matter of all or nothing. That could be my rusty condition having been so long since I played the piano. The farthest I ever got was just learning and noodling although I had developed some comfort and dexterity and had grown somewhat accustomed to it. It is not like I have a lifetime of muscle memory that would easily reawaken after a yearlong and particularly distracting break. Hopefully it is just a matter of tracking down something like a box needing to be checked or unchecked.
  5. I have a Casio PX150 connected to my Mac using the USB cable. It is communicating and using Garageband for sounds but the volume is significantly low even at the computer's maximum volume setting. It also requires impractical key force to generate volume. It produces a strong as should be expected signal according to the DAW meters but the actual audio I hear through headphones is weak. The same is true when hooked up to Kontakt and 3rd party sample software. I see a good signal tripping the meters but this is not reflected in the signal through my headphones. The headphones are fine. I use them everyday. Regardless, I have tried two different pairs while testing the setup using a Mac Pro, Mac Mini and Macbook Pro. Each computer has a different OS version but they all meet the minimum requirements. It has not displayed this problem in the past. I was able to use the piano without this problem. It has been over a year since I used the piano. The keyboard has sat in the same place. It was under a dust cover. I just did not have time to play it. I doubt it is related to failure in the hardware. I had disconnected the USB cable because during the time I was not playing I had acquired the Mac Pro and shifted my desktop area to accommodate two systems and three ACD's. There must be something in the settings I am doing wrong. I have only set up the connection a few times. But I was able to do it without a problem each time. Usually the keyboard was connected and I just turned it on and opened software. I tried different sequences turning each on first. Reconnecting the keyboard I could have forgotten a setting or something. I read the user guide and it is a very simple process. There is nothing like this in the trouble shooting section. Sharing any ideas would be greatly appreciated.
×