Jump to content
Gregory

WK-6500 Drums missing from SD Card

Recommended Posts

Hi,

I have been creating and recording tracks using 'Easy Record' and the song sequencer.  The playback on the Keyboard is fine.  After I load the file on an SD card (using smf midi) and play it on my computer the drums are missing.  I have tried a couple of different SD cards, and even edited the soundtrack to create my own user rhythm but the problem persists -- no drums.  Anyone have any idea how to correct this?

Gregory

Share this post


Link to post
Share on other sites

Gregory

 

We are going to need a little more detail about your record/playback procedures.  Are you recording just drums, so that you get only silence on playback, or are you also recording melodic instruments that playback OK, with just the drums missing?  When you play the SMF back from the PC, are you playing it back to the WK-6500's internal tone module, to the PC's Microsoft Wavetable Synth, or to some other wavetable type sound module on the PC?  What software or MIDI file player are you using on the PC to playback the SMF?  Lastly, after you have completed your original "take", are you trying to add anything to it or in any way edit it before you convert it to the SMF?  I think I can probably guess what you are running into, but if I enter that here, now, and I am wrong, then this entire discussion can get really confusing really fast, so better that I have a little more info before I say any more.

 

 

Share this post


Link to post
Share on other sites

Hi Ted,

As mentioned before I am using the Song Sequencer with Easy Record. I am recording melodic tracks with full accompaniment.  I have also used a combination of different starts (L-13 to L-17).  The playback on the keyboard is fine.   When I load the Sd card from the KB and place it in the PC everything plans except for the drums. I have also converted the fileto MP3 and wav from my PC but it made no difference. I downloaded the Data Manager 6.1 from world Casio  but I am not sure how to use that with the SD card. Moreover I am not sure what midi file player is on my PC. Whatever came with the computer. I also tried turning off B10 from the mixer but for some reason it will not stay off when I record. Finally I have made several tracks for different songs using the same procedure but the problem persists. Hope this helps. 

Gregory

 

i forgot to mention that I played it on my PC using a couple of different apps: windows media player and Grove Music. I am using windows 10

Edited by Gregory
Left out a couple of details.

Share this post


Link to post
Share on other sites

OK Gregory

 

That is pretty much what I had guessed, but there is one major point that still does not make any sense to me, but we will see if we can get this headed down the right road anyway.  I see you have already reviewed the reply I made to GLB on this topic back on 03-20-2016, so that will help.  The CTK/WK-6XXX/7XXX Song Sequencer is actually a 32 track recording device - 16 "real" (hardware) tracks (B01-B16) and a 17th "real" hardware track (the System Track) that contains the 16 "virtual" tracks (A01-A16).  The "Easy Record" procedure records a complete performance, including all Auto-Accompaniment features to the virtual "A" tracks, but this is a one-pass, erase as it records procedure.  You can not add any additional data to any of those "A" tracks.  Any attempt to do so will erase all previously recorded "A" tracks.  For that we have the "B" tracks, using the "track-at-a-time" or "specific track" recording procedure, which will allow us to add additional tracks to our song without losing any previously recorded "A" track data.  So, there is any likelihood that we could end up with a 32 track song, and this is fine as long as it remains in the Casio proprietary "CMS" Song Sequencer format.  You can even save that to an SD Card as a CMS file and pass it on to a friend with a similar model Casio keyboard and it will play just fine, but when we want to save it to a Standard MIDI FIle (SMF), by definition of the official MIDI Spec the SMF can only have 16 tracks, so something has to give, and for that we have the Mixer Part-ON/OFF menu.  When the CMS file is converted to SMF, any "A" track (Easy Record) data for which the correspondingly numbered "B" tack is not turned OFF in the Mixer, will not convert, and will not appear in the SMF.  This is the point I do not understand in what you are getting.  If you are not turning OFF any "B" tracks, I do not see how you are getting anything, but I do not want to get hung up on that here. For now, I will just state my recommended procedure for those who want to make an SMF from only "A" track (Easy Record) data and have no added "B" track data to preserve: Power on and set up the keyboard the way you want, but do not turn OFF any "B" tracks in the Mixer at this point.  However, if there are any Rhythm parts that you do no want recorded, that "A" track part should be turned OFF at this point.  Press the "Record" button and record (Easy Record) your performance.  When the recording is finished, it will automatically save to a CMS file in intermal memory.  At this point, it may be wise to save your original performance to a CMS file on the SD Card as a back up.  Once that is done, and with your performance still selected in the Song Sequencer, go into the Mixer, turn OFF ALL of the "B" tracks and immediately save/convert it to an SMF on the SD Card.  You were headed in the right direction by turning OFF "B-10", but you were not doing if at the right time.  You do it right before converting, not at the start of recording.  Give this a try and see if it helps.

 

Good luck!  Let us know how things turn out.

Share this post


Link to post
Share on other sites

Hi,

Thanks for your reply.  I followed your instructions but the result was not as hoped for.  When I turned off all the B tracks before saving the file, there was no CMS or SMF file to save.  All that came up on the screen was USERNAME.AC7.  I decided to save the file anyway and give it a try but nothing came of it.  I couldn't even open the file on my PC.  Hence, I went back to my Keyboard and decided to load the file again with just the B10 track turned off.  This time the CMS and SMF files were there and I did that save as instructed.  However, the drums were still missing from the playback on the SD card when played on my PC (all other tracks were fine).  The playback on the Keyboard is also fine.  Any other suggestions?

Gregory

Share this post


Link to post
Share on other sites

When FILENAME.AC7 appears on the display, you are set up to save a User Rhythm file.  The very top line of the display should be indicating this with the statement "-Rhythm Save-".  Those Down/Up Arrow indicators to the right of the words "Rhythm Save" on the display indicate that this is a multi-page menu.  You need to continue pressing the Down Arrow button until "Seq SmfSave" appears on the top line of the display.  If you miss it and go too far, use the Up Arrow button to come back to it.  You can then use the Left/Right Arrow and - / + buttons to name the file you are about to save/convert, then press the Enter button, when you are finished with the naming procedure, to actually start the conversion process.  This is covered in Items 5 through 8 of the left hand column of Page E-105 of the manual, but you have had to have been doing this correctly in the past, or you would never have generated an SMF to begin with.  Since you have not recorded anything to the "B" tracks, you really don't need to worry about turning them OFF.  That only becomes an issue if they have data recorded to them.  I just recommend turning them all off as a trouble shooting procedure when the resulting SMF file has tracks missing from it, as erroneous "B" track data is usually the culprit.  For some reason, even though you are getting a complete CMS file, the drum track is not converting.  Other than having data on Track B-10, I can not explain why, but I no longer have any of my CTK/WK-6XXX/7XXX units to experiment with, so having you attach a copy of the CMS file would do me no good, as I have nothing that will load it.  So, if you don't mind, try attaching a copy of your SMF file.  I could load it into Sonar and see if the drum track is completely missing, or if it is getting converted to the wrong track.  If it is missing completely, that could be either a WK-6500 sequencer defect or a procedural problem on your part, but if it is getting converted to the wrong track, that almost has to be a WK-6500 sequencer defect.

 

Share this post


Link to post
Share on other sites

Hi, Thanks again and I really appreciate your help but why the drums are not converting is still a mystery. I have recorded a number of SMS files using the Song Sequencer and easy record and noticed that the drums are missing on them all. I even tried the same recording just today on a wk-6600 model and the results were the same - everything but the drums. I have reread your instructions several times as well as the manual, and have tried several scenarios but I am still stumped.  It could very well be something that I am doing wrong but I wonder if it could be could also be my PC. For now we will have to leave it be. Thanks again for all your help. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×