Jump to content
Ali Arslan

Casio LK-41 shows up as Unknown Device (And a message pops us on connection 'USB not recognized')

Recommended Posts

I have recently bought a used Casio LK-41 (Japanese Language). It has a Midi Usb port. I have been trying to connect it to my Dell N4050 laptop to use it as a midi controller device with Reaper, but it is not connecting properly.

I have tried 4 different midi cables of various lengths, but no luck. I have tried to connect it to another laptop as well, but I get the same error.

I have tried tons of different drivers; none of them work. In the device manager, it should show under Sound and Game Controllers, but it always appears as an Unknown Device under Universal Serial Bus Controllors.

I used to have Windows 10 64-bit; I switched to Windows 7 32-bit, then to Windows 7 64-bit in a hope to resolve the issue, but all in vain.

I have done a lot of research. But I haven't been able to find any solution. I would really appreciate if a professional would help me out please!

P.S. I am considering the following solutions at the moment: 1. Switching to Windows XP 32-Bit. 2. Joining 2 Midi Cables in order to attach the Piano to two USB ports at once (In case, if it is an issue of the piano not getting enough voltage).

Share this post


Link to post
Share on other sites

Hey there. Well the last idea you had (connecting 2 cables) will do nothing -- the LK doesn't get power from the USB -- it only is for MIDI.

 

My *guess* is this a a driver / OS clashing issue. I am a little concerned when you say you downloadied "tons" of different drivers... there is only one official one at:

http://support.casio.com/en/support/download.php?cid=008&pid=75

 

Something to try: Create a new user profile in Windowns, and running in Windows Vista® (32-bit)/®7(32-bit)/®8(32-bit)/®8.1(32-bit). Worth a shot! :-) 

 

 

Share this post


Link to post
Share on other sites

You're right. Connecting 2 cables didn't work. My laptop (Dell N4050) didn't accept XP installation, so couldn't try that.

 

By tons of drivers, I meant, Casio (incl. the one you mentioned in the link), Yamaha, Korg, and God knows which driver I have installed. None of them worked. I even force installed Casio driver as Legacy driver. It appeared in Sound and Game Controller category, but when I connected my Piano, it still appeared as an Unknown Device under Universal Bus Controllers category.

 

I currently have Windows 7-64 bit installed. Tired of switching between windows.

 

My USB ports are fine, I have tested them with other devices like Hard Disks, Mice etc. It has to be either the Driver, the Cable or may be Piano's USB port might be damaged.

Share this post


Link to post
Share on other sites

Just tested the Piano's USB port with tester. It is live (tester's bulb lit up). Is it supposed to be this way?

 

I have managed to convert Audio from the Piano to Midi signal through Reatune plugin in Reaper. But it has a lot of latency and it is not accurate. Are there any tried and tested solutions for Audio to Midi?

Share this post


Link to post
Share on other sites

Ali,

 

To recap some of Scott's comments:

 

If you are trying to power the LK-41 from the USB port, that will not work.  Power the LK-41 from batteries or the proper power adapter.

 

Most keyboard drivers have a Manufacturer ID embedded in them.  If the ID in the driver does not match the ID in the keyboard's firmware, they will not connect, so it is not surprising that the Yamaha and Korg drivers would not work.  In the early days of Vista-64, Casio did not write a 64 bit driver for the WK-3800, so I had to modify a Roland-Edirol 64 bit driver.  All I had to do was replace the Roland ID in the driver with the Casio ID, and it worked fine.

 

Speaking of drivers, the bit depth of the driver MUST match the bit depth of the operating system.  Drivers are essentially "plug-ins". You can not connect a 64 bit "plug-in" to a 32 bit socket and vice versa - and Compatibility Mode can not correct for this.  Compatibility Mode is for programs, not drivers and plug-ins.  Here again, in the early days of 64 bit operating systems, those who were quick to upgrade found that suddenly none of their 32 bit VSTi plug-ins would work anymore.  They had a choice of back-leveling their OS or doing without their VSTi plug-ins until the plug-in authors could write 64 bit versions.

 

Also, speaking of drivers, before proceeding further, you may want to uninstall any of those "tons" of erroneous drivers that may still be on your system so as to avoid any unseen conflicts.

 

Go to the following site:

http://support.casio.com/en/support/download.php?cid=008&pid=20

 

Scroll down to the Drivers section.

 

Since you are now running Win-7 64 bit, you want the following driver:

 

Digital Keyboards/ Pianos/ Key Lighting Digital Piano PL-40R

Windows® 7(64-bit)/® 8(64-bit)/®
 8.1(64-bit) Version 1.2

 

 

When you click on that driver, you will get the following message:

 

[Drivers] Windows® 7(64-bit)/® 8(64-bit)/® 8.1(64-bit) - Version 1.2

 

Supported Models


CTK-710/ CTK-720/ CTK-800/ CTK-810/ CTK-810IN/ CT-599/ CT-799/ LK-90/ LK-92TV/ LK-180TV/ LK-280CDTV/ LK-93TV/ LK-94/ LK-95TV/ LK-201TV/ LK-202TV/ LK-203TV/ LK-300TV/ LK-41/ LK-200S/ LK-210/ LK-301BB/ LK-70S/ WK-110/ WK-3300/ WK-3800/ WK-8000/ PX-400R/ PX-200/ PX-320/ PX-410R/ PX-575R/ PX-800/ AP-80R/ AP-500/ PL-40R/

 

Notice that the LK-41 is specifically listed as one of the compatible devices.

 

Many Casio users are successfully using this driver for Windows-10.  The only reason that Windows-10 is not listed is because it had not been released yet, when this site was posted, but as you have already discovered, certain combinations of Windows-10 and some computer hardware have problems with USB-MIDI.  I suspect it has something to do with the computer's firmware bios.

 

The LK-41 is not "Class Compliant".  It will not work with the driver that is built-in to Windows, so download and install the above driver onto you Win-7/64 system.

 

In closing, the Audio-to-MIDI converters you asked about are pretty gimmicky.  They work, after a fashion, for simple, single note at a time, passages, but for complex scores with full chords, harmony, passing tones, etc, they usually fall flat.

 

Best of luck - I hope this gets you going!

 

Share this post


Link to post
Share on other sites

tnicoson First of all, thank you so much for the detailed reply and guidance.

 

After so many days of trial and research, I had figured most of what you had mentioned out. The final conclusion is that the Keyboard has a hardware issue. Most probably, its USB port is damaged.

 

Thank you guys for your support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×